OWA 2013 goes public

Public or Shared Computer?
That used to be the “Big Question” when logging on to OWA having Form-Based Authentication enabled (=default setting in Exchange 2007/2010/2013 and had to be manually enabled in Exchange 2003).

OWA2013Now with Outlook Web App 2013, the option to choose public or private computer is not enabled by default, but we can enable it in Exchange Management Shell (EMS).

Example:
Set-OwaVirtualDirectory -id "EX2013\owa (Default Web Site)" -LogonPagePublicPrivateSelectionEnabled $True
[Read more…]

Exchange 2013 RTM CU2 Upgrade Failed

I was recently contacted regarding a problem with upgrading Exchange 2013 RTM CU1 (Build Number: 15.0.620.29) Multi-Role Servers to CU2  (Build Number: 15.0.712.24). The Customer got the same error on all his five Multi-Role Servers:  Mailbox service FAILED

PS L:\install2\2013 CU2\extracted> setup.exe /IAcceptExchangeServerLicenseTerms /m:upgrade
Welcome to Microsoft Exchange Server 2013 Cumulative Update 1 Unattended Setup
Languages
Mailbox role: Transport service
Client Access role: Front End Transport service
Mailbox role: Client Access service
Mailbox role: Unified Messaging service
Mailbox role: Mailbox service
Management tools
Client Access role: Client Access Front End service

Performing Microsoft Exchange Server Prerequisite Check

Configuring Prerequisites COMPLETED
Prerequisite Analysis COMPLETED

Configuring Microsoft Exchange Server

Language Files COMPLETED
Restoring Services COMPLETED
Language Configuration COMPLETED
Mailbox role: Transport service COMPLETED
Client Access role: Front End Transport service COMPLETED
Mailbox role: Client Access service COMPLETED
Mailbox role: Unified Messaging service COMPLETED
Mailbox role: Mailbox service FAILED
The following error was generated when “$error.Clear();
Install-MsiPackage `
-PackagePath ([System.IO.Path]::Combine($RoleLanguagePacksPath, “Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi”)) `
-PropertyValues (“ARPSYSTEMCOMPONENT=1 ALLUSERS=1”) `
-LogFile ([System.IO.Path]::Combine($RoleSetupLoggingPath, “InstallSpeech-ca-ES.msilog”))
” was run: “Couldn’t open package ‘C:\Program Files\Microsoft\Exchange Server\V15\bin\Setup\ServerRoles\UnifiedMessaging\MSSpeech_SR_TELE.ca-ES.msi’. This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. Error code is 1619.”.

[Read more…]